Загрузка данных
dmitriev-aal@VDI-Dmitriev-A:~/Desktop$ kubectl --context devstbl -n kube-system get pods -l k8s-app=kube-dns -o wide
NAME READY STATUS RESTARTS AGE IP NODE NOMINATED NODE READINESS GATES
coredns-6c59896785-69pvv 1/1 Running 0 104d 100.68.150.247 afs1app-m-001 <none> <none>
coredns-6c59896785-pflvn 1/1 Running 0 157d 100.68.161.61 afs2app-m-004 <none> <none>
dmitriev-aal@VDI-Dmitriev-A:~/Desktop$ kubectl --context devstbl -n kube-system exec coredns-6c59896785-69pvv -- cat /etc/resolv.conf
error: Internal error occurred: error executing command in container: failed to exec in container: failed to start exec "dc9addc257b2b3b768f3c14b0304c28ce65212b962e810f071e3c715b5b2dd3a": OCI runtime exec failed: exec failed: unable to start container process: exec: "cat": executable file not found in $PATH: unknown
dmitriev-aal@VDI-Dmitriev-A:~/Desktop$ kubectl --context devstbl -n kube-system get configmap node-local-dns -o yaml
apiVersion: v1
data:
Corefile: |
cluster.local:53 {
errors
cache {
success 9984 30
denial 9984 5
}
reload
loop
bind __PILLAR__LOCAL__DNS__
forward . __PILLAR__CLUSTER__DNS__ {
force_tcp
}
prometheus :9253
health __PILLAR__LOCAL__DNS__:8080
}
in-addr.arpa:53 {
errors
cache 30
reload
loop
bind __PILLAR__LOCAL__DNS__
forward . __PILLAR__CLUSTER__DNS__ {
force_tcp
}
prometheus :9253
}
ip6.arpa:53 {
errors
cache 30
reload
loop
bind __PILLAR__LOCAL__DNS__
forward . __PILLAR__CLUSTER__DNS__ {
force_tcp
}
prometheus :9253
}
.:53 {
errors
cache 30
reload
loop
bind __PILLAR__LOCAL__DNS__
forward . __PILLAR__UPSTREAM__SERVERS__ {
force_tcp
}
prometheus :9253
}
kind: ConfigMap
metadata:
annotations:
kubectl.kubernetes.io/last-applied-configuration: |
{"apiVersion":"v1","data":{"Corefile":"cluster.local:53 {\n errors\n cache {\n success 9984 30\n denial 9984 5\n }\n reload\n loop\n bind __PILLAR__LOCAL__DNS__\n forward . __PILLAR__CLUSTER__DNS__ {\n force_tcp\n }\n prometheus :9253\n health __PILLAR__LOCAL__DNS__:8080\n}\nin-addr.arpa:53 {\n errors\n cache 30\n reload\n loop\n bind __PILLAR__LOCAL__DNS__\n forward . __PILLAR__CLUSTER__DNS__ {\n force_tcp\n }\n prometheus :9253\n}\nip6.arpa:53 {\n errors\n cache 30\n reload\n loop\n bind __PILLAR__LOCAL__DNS__\n forward . __PILLAR__CLUSTER__DNS__ {\n force_tcp\n }\n prometheus :9253\n}\n.:53 {\n errors\n cache 30\n reload\n loop\n bind __PILLAR__LOCAL__DNS__\n forward . __PILLAR__UPSTREAM__SERVERS__ {\n force_tcp\n }\n prometheus :9253\n}\n"},"kind":"ConfigMap","metadata":{"annotations":{},"labels":{"addonmanager.kubernetes.io/mode":"Reconcile","kubeone.io/addon":"nodelocaldns","kubeone.io/component":"nodelocaldns"},"name":"node-local-dns","namespace":"kube-system"}}
creationTimestamp: "2022-05-17T02:21:38Z"
labels:
addonmanager.kubernetes.io/mode: Reconcile
kubeone.io/addon: nodelocaldns
kubeone.io/component: nodelocaldns
name: node-local-dns
namespace: kube-system
resourceVersion: "23580094897"
uid: 979c0438-5505-4b8f-a20c-a50a75c29f74
dmitriev-aal@VDI-Dmitriev-A:~/Desktop$ kubectl --context devstbl -n kube-system get svc kube-dns -o wide
NAME TYPE CLUSTER-IP EXTERNAL-IP PORT(S) AGE SELECTOR
kube-dns ClusterIP 100.68.0.10 <none> 53/UDP,53/TCP,9153/TCP 5y181d k8s-app=kube-dns
dmitriev-aal@VDI-Dmitriev-A:~/Desktop$ kubectl --context devstbl -n kube-system get ds node-local-dns -o wide
NAME DESIRED CURRENT READY UP-TO-DATE AVAILABLE NODE SELECTOR AGE CONTAINERS IMAGES SELECTOR
node-local-dns 95 95 95 95 95 <none> 4y93d node-cache registry-proxy.rshbdev.ru/dns/k8s-dns-node-cache:1.22.13 k8s-app=node-local-dns
dmitriev-aal@VDI-Dmitriev-A:~/Desktop$