Загрузка данных


dmitriev-aal@VDI-Dmitriev-A:~$ kubectl get pods | grep self-em
owf-ms-prd-self-employment-pfm-7975f74f69-6rhzl                   2/2     Running            0            9h
self-employment-7bb6469b4b-6pjl7                                  0/2     Init:0/1           0            9h
self-employment-fns-adapter-mock-75f6f86dd5-68gdq                 2/2     Running            0            9h
self-employment-frontend-86c8788d99-wxn4z                         1/2     ImagePullBackOff   0            10h
self-employment-ui-557b99674-cfxnn                                2/2     Running            0            10h
dmitriev-aal@VDI-Dmitriev-A:~$ kubectl describe pod self-employment-7bb6469b4b-6pjl7
Name:                 self-employment-7bb6469b4b-6pjl7
Namespace:            isys-ownfin
Priority:             0
Priority Class Name:  rumsk1
Service Account:      default
Node:                 afs1asd-wl-241/10.21.182.184
Start Time:           Thu, 01 Oct 2026 01:17:24 +0300
Labels:               app=self-employment
                      chart=base-1.15.3
                      fullname=self-employment
                      heritage=Helm
                      isys=ownfin
                      pod-template-hash=7bb6469b4b
                      psvc=self-employment
                      release=self-employment
                      security.istio.io/tlsMode=istio
                      service.istio.io/canonical-name=self-employment
                      service.istio.io/canonical-revision=0.8.6
                      version=0.8.6
                      workload.topology.app.farm/zone=rumsk1
Annotations:          checksum/configMapsEnv: a1ebcd28658ea41291ddec2c7c968b4610db843679d5b83e94ba19327d5c0665
                      checksum/secretEnv: e8c31bbdad18c8873501c32f90eb6f0c7d00cc483be9c5cc65a5d5f9f7234e9d
                      inject.istio.io/templates: sidecar,custom
                      kubectl.kubernetes.io/default-container: app
                      kubectl.kubernetes.io/default-logs-container: app
                      kubectl.kubernetes.io/restartedAt: 2025-09-10T01:18:03+03:00
                      prometheus.io/path: /stats/prometheus
                      prometheus.io/port: 15020
                      prometheus.io/scrape: true
                      sidecar.istio.io/status:
                        {"initContainers":["istio-init"],"containers":["istio-proxy"],"volumes":["istio-certs","workload-socket","credential-socket","workload-cer...
                      sidecar.istio.io/userVolume: [{"name": "wasmfilters-dir","configMap": {"name": "ownfin-envoy-filters"}}]
                      sidecar.istio.io/userVolumeMount: [{"mountPath":"/var/local/lib/wasm-filters","name":"wasmfilters-dir"}]
Status:               Pending
IP:                   
IPs:                  <none>
Controlled By:        ReplicaSet/self-employment-7bb6469b4b
Init Containers:
  istio-init:
    Container ID:  
    Image:         registry.rshbdev.ru/appfarm/infra/images/istio/proxyv2:1.15.1-rshb.0.4.0
    Image ID:      
    Port:          <none>
    Host Port:     <none>
    Args:
      istio-iptables
      -p
      15001
      -z
      15006
      -u
      1337
      -m
      REDIRECT
      -i
      *
      -x
      
      -b
      *
      -d
      15090,15021,15020
      --log_output_level=default:info
    State:          Waiting
      Reason:       PodInitializing
    Ready:          False
    Restart Count:  0
    Limits:
      cpu:     400m
      memory:  412Mi
    Requests:
      cpu:        10m
      memory:     64Mi
    Environment:  <none>
    Mounts:       <none>
Containers:
  istio-proxy:
    Container ID:  
    Image:         registry.rshbdev.ru/appfarm/infra/images/istio/proxyv2:1.15.1-rshb.0.4.0
    Image ID:      
    Port:          15090/TCP (http-envoy-prom)
    Host Port:     0/TCP (http-envoy-prom)
    Args:
      proxy
      sidecar
      --domain
      $(POD_NAMESPACE).svc.cluster.local
      --proxyLogLevel=warning
      --proxyComponentLogLevel=misc:error
      --log_output_level=default:info
      --concurrency
      2
    State:          Waiting
      Reason:       PodInitializing
    Ready:          False
    Restart Count:  0
    Limits:
      cpu:     400m
      memory:  412Mi
    Requests:
      cpu:      10m
      memory:   64Mi
    Readiness:  http-get http://:15021/healthz/ready delay=1s timeout=3s period=2s #success=1 #failure=30
    Environment:
      HTTP_LOG_FORWARDER_HOST:        (v1:spec.nodeName)
      HTTP_LOG_FORWARDER_PORT:       9000
      HTTP_LOG_FORWARDER_ENDPOINT:   /
      OUTPUT_CERTS:                  /etc/istio-certs/
      ISYS_NAME:                      (v1:metadata.labels['isys'])
      PSVC_NAME:                      (v1:metadata.labels['psvc'])
      WORKLOAD_ZONE_NAME:             (v1:metadata.labels['workload.topology.app.farm/zone'])
      JWT_POLICY:                    third-party-jwt
      PILOT_CERT_PROVIDER:           istiod
      CA_ADDR:                       istiod.istio-system.svc:15012
      POD_NAME:                      self-employment-7bb6469b4b-6pjl7 (v1:metadata.name)
      POD_NAMESPACE:                 isys-ownfin (v1:metadata.namespace)
      INSTANCE_IP:                    (v1:status.podIP)
      SERVICE_ACCOUNT:                (v1:spec.serviceAccountName)
      HOST_IP:                        (v1:status.hostIP)
      PROXY_CONFIG:                  {"tracing":{"zipkin":{"address":"jaeger-collector.istio-system:9411"},"customTags":{"workload.topology.app.farm/zone":{"environment":{"name":"WORKLOAD_ZONE_NAME"}}},"sampling":100}}
                                     
      ISTIO_META_POD_PORTS:          [
                                     ]
      ISTIO_META_APP_CONTAINERS:     app
      ISTIO_META_CLUSTER_ID:         Kubernetes
      ISTIO_META_INTERCEPTION_MODE:  REDIRECT
      ISTIO_META_WORKLOAD_NAME:      self-employment
      ISTIO_META_OWNER:              kubernetes://apis/apps/v1/namespaces/isys-ownfin/deployments/self-employment
      ISTIO_META_MESH_ID:            cluster.local
      TRUST_DOMAIN:                  cluster.local
      ISTIO_PROMETHEUS_ANNOTATIONS:  {"scrape":"true","path":"/metrics","port":"8080"}
      ISTIO_KUBE_APP_PROBERS:        {"/app-health/app/livez":{"httpGet":{"path":"/health/liveness","port":8080,"scheme":"HTTP"},"timeoutSeconds":1},"/app-health/app/readyz":{"httpGet":{"path":"/health/readiness","port":8080,"scheme":"HTTP"},"timeoutSeconds":1}}
    Mounts:
      /etc/istio-certs/ from istio-certs (rw)
      /etc/istio/pod from istio-podinfo (rw)
      /etc/istio/proxy from istio-envoy (rw)
      /var/lib/istio/data from istio-data (rw)
      /var/local/lib/wasm-filters from wasmfilters-dir (rw)
      /var/run/secrets/credential-uds from credential-socket (rw)
      /var/run/secrets/istio from istiod-ca-cert (rw)
      /var/run/secrets/tokens from istio-token (rw)
      /var/run/secrets/workload-spiffe-credentials from workload-certs (rw)
      /var/run/secrets/workload-spiffe-uds from workload-socket (rw)
  app:
    Container ID:   
    Image:          registry.rshbdev.ru/rshbintech/crft/ckof/ownfin/backend/prd/self-employment:0.8.6
    Image ID:       
    Port:           <none>
    Host Port:      <none>
    State:          Waiting
      Reason:       PodInitializing
    Ready:          False
    Restart Count:  0
    Limits:
      cpu:     500m
      memory:  1Gi
    Requests:
      cpu:      300m
      memory:   500Mi
    Liveness:   http-get http://:15020/app-health/app/livez delay=180s timeout=1s period=5s #success=1 #failure=5
    Readiness:  http-get http://:15020/app-health/app/readyz delay=60s timeout=1s period=4s #success=1 #failure=3
    Environment Variables from:
      self-employment-app-cm-env      ConfigMap  Optional: false
      self-employment-app-secret-env  Secret     Optional: false
    Environment:                      <none>
    Mounts:
      /secrets from app-vault-secrets (ro)
Conditions:
  Type              Status
  Initialized       False 
  Ready             False 
  ContainersReady   False 
  PodScheduled      True 
Volumes:
  istio-certs:
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    Medium:     Memory
    SizeLimit:  <unset>
  workload-socket:
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    Medium:     
    SizeLimit:  <unset>
  credential-socket:
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    Medium:     
    SizeLimit:  <unset>
  workload-certs:
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    Medium:     
    SizeLimit:  <unset>
  istio-envoy:
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    Medium:     Memory
    SizeLimit:  <unset>
  istio-data:
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    Medium:     
    SizeLimit:  <unset>
  istio-podinfo:
    Type:  DownwardAPI (a volume populated by information about the pod)
    Items:
      metadata.labels -> labels
      metadata.annotations -> annotations
  istio-token:
    Type:                    Projected (a volume that contains injected data from multiple sources)
    TokenExpirationSeconds:  43200
  istiod-ca-cert:
    Type:      ConfigMap (a volume populated by a ConfigMap)
    Name:      istio-ca-root-cert
    Optional:  false
  wasmfilters-dir:
    Type:      ConfigMap (a volume populated by a ConfigMap)
    Name:      ownfin-envoy-filters
    Optional:  false
  app-vault-secrets:
    Type:              CSI (a Container Storage Interface (CSI) volume source)
    Driver:            secrets-store.csi.k8s.io
    FSType:            
    ReadOnly:          true
    VolumeAttributes:      secretProviderClass=self-employment-app-secret-provider
QoS Class:             Burstable
Node-Selectors:        workload.topology.app.farm/zone=rumsk1
Tolerations:           node.kubernetes.io/not-ready:NoExecute op=Exists for 300s
                       node.kubernetes.io/unreachable:NoExecute op=Exists for 300s
                       workload.topology.app.farm/zone:NoSchedule op=Exists
Events:
  Type     Reason       Age                   From     Message
  ----     ------       ----                  ----     -------
  Warning  FailedMount  6m12s (x301 over 9h)  kubelet  (combined from similar events): Unable to attach or mount volumes: unmounted volumes=[app-vault-secrets], unattached volumes=[app-vault-secrets credential-socket istiod-ca-cert istio-certs workload-certs istio-podinfo istio-envoy wasmfilters-dir istio-data istio-token workload-socket]: timed out waiting for the condition
  Warning  FailedMount  58s (x271 over 9h)    kubelet  MountVolume.SetUp failed for volume "app-vault-secrets" : rpc error: code = Unknown desc = failed to mount secrets store objects for pod isys-ownfin/self-employment-7bb6469b4b-6pjl7, err: rpc error: code = Unknown desc = error making mount request: {manual_kv_production/data/rshbintech/crft/ckof/ownfin/backend/prd/self-employment}: {key "EKASSIR_HTTP_REQUEST_PARAMETER_CONTENT_TYPE" does not exist at the secret path}
dmitriev-aal@VDI-Dmitriev-A:~$ kubectl get logs -c app self-employment-7bb6469b4b-6pjl7
error: unknown shorthand flag: 'c' in -c
See 'kubectl get --help' for usage.
dmitriev-aal@VDI-Dmitriev-A:~$ kubectl get logs self-employment-7bb6469b4b-6pjl7 -c app 
error: unknown shorthand flag: 'c' in -c
See 'kubectl get --help' for usage.
dmitriev-aal@VDI-Dmitriev-A:~$ kubectl logs self-employment-7bb6469b4b-6pjl7 -c app 
Error from server (BadRequest): container "app" in pod "self-employment-7bb6469b4b-6pjl7" is waiting to start: PodInitializing
dmitriev-aal@VDI-Dmitriev-A:~$ kubectl logs self-employment-7bb6469b4b-6pjl7 -c app --previous
Error from server (BadRequest): previous terminated container "app" in pod "self-employment-7bb6469b4b-6pjl7" not found
dmitriev-aal@VDI-Dmitriev-A:~$ kubectl get events | grep self-employment-7bb6469b4b-6pjl7
2m8s        Warning   FailedMount              pod/self-employment-7bb6469b4b-6pjl7                                                 MountVolume.SetUp failed for volume "app-vault-secrets" : rpc error: code = Unknown desc = failed to mount secrets store objects for pod isys-ownfin/self-employment-7bb6469b4b-6pjl7, err: rpc error: code = Unknown desc = error making mount request: {manual_kv_production/data/rshbintech/crft/ckof/ownfin/backend/prd/self-employment}: {key "EKASSIR_HTTP_REQUEST_PARAMETER_CONTENT_TYPE" does not exist at the secret path}
7m22s       Warning   FailedMount              pod/self-employment-7bb6469b4b-6pjl7                                                 (combined from similar events): Unable to attach or mount volumes: unmounted volumes=[app-vault-secrets], unattached volumes=[app-vault-secrets credential-socket istiod-ca-cert istio-certs workload-certs istio-podinfo istio-envoy wasmfilters-dir istio-data istio-token workload-socket]: timed out waiting for the condition
dmitriev-aal@VDI-Dmitriev-A:~$